What’s Vulnerable › Vulnerabilities
CVE-2026-33889: ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-15 · updated 2026-10-26
- Weakness: CWE-79
Description
ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain a stored cross-site scripting vulnerability in the @apostrophecms/color-field module, where color values prefixed with -- bypass TinyColor validation intended for CSS custom properties, and the launder.string() call performs only type coercion without stripping HTML metacharacters. These unsanitized values are then concatenated directly into <style> tags both in per-widget style elements rendered for all visitors and in the global stylesheet rendered for editors, with the output marked as safe HTML. An editor can inject a value which closes the style tag and executes arbitrary JavaScript in the browser of every visitor to any page containing the affected widget. This enables mass session hijacking, cookie theft, and privilege escalation to administrative control if an admin views draft content. This issue has been fixed in version 4.29.0.
Affected products
- apostrophecms apostrophe: before 4.29.0 — fixed in 4.29.0
How to fix
Upgrade to a fixed version: apostrophecms apostrophe 4.29.0. Check the vendor advisory for mitigations.
References
- https://github.com/apostrophecms/apostrophe/commit/6a89bdb7acdb2e1e9bf1429961a6ba7f99410481
- https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-97v6-998m-fp4g
- https://github.com/apostrophecms/apostrophe/security/advisories/GHSA-97v6-998m-fp4g
Get alerted when CVE-2026-33889 or the next vulnerability affects your stack