What’s Vulnerable › Vulnerabilities
CVE-2026-33896: Forge has a basicConstraints bypass in its certificate chain verification (RFC 5280 violation)
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-27 · updated 2026-10-26
- Weakness: CWE-295
Description
Forge (also called `node-forge`) is a native implementation of Transport Layer Security in JavaScript. Prior to version 1.4.0, `pki.verifyCertificateChain()` does not enforce RFC 5280 basicConstraints requirements when an intermediate certificate lacks both the `basicConstraints` and `keyUsage` extensions. This allows any leaf certificate (without these extensions) to act as a CA and sign other certificates, which node-forge will accept as valid. Version 1.4.0 patches the issue.
Affected products
- digitalbazaar forge: through 1.3.3
- Npm Node-Forge: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: Npm Node-Forge 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/digitalbazaar/forge/commit/2e492832fb25227e6b647cbe1ac981c123171e90
- https://github.com/digitalbazaar/forge/security/advisories/GHSA-2328-f5f3-gj25
- https://access.redhat.com/errata/RHSA-2026:13826
- https://access.redhat.com/errata/RHSA-2026:24761
- https://access.redhat.com/errata/RHSA-2026:34342
- https://access.redhat.com/errata/RHSA-2026:9742
- https://access.redhat.com/security/cve/CVE-2026-33896
- https://bugzilla.redhat.com/show_bug.cgi?id=2452458
- https://github.com/digitalbazaar/forge/security/advisories/GHSA-2328-f5f3-gj25
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33896.json
Get alerted when CVE-2026-33896 or the next vulnerability affects your stack