What’s Vulnerable › Vulnerabilities
CVE-2026-33900: ImageMagick has a Heap overflow caused by integer overflow/wraparound in viff encoder on 32-bit builds
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-13 · updated 2026-06-17
- Weakness: CWE-190
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. In versions below both 7.1.2-19 and 6.9.13-44, the viff encoder contains an integer truncation/wraparound issue on 32-bit builds that could trigger an out of bounds heap write, potentially causing a crash. This issue has been fixed in versions 6.9.13-44 and 7.1.2-19.
Affected products
- ImageMagick: before 6.9.13-44; from 7.0.0-0 before 7.1.2-19 — fixed in 6.9.13-44, 7.1.2-19
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-44, 7.1.2-19. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/d27b840a61b322419a66d0d192ff56d52498148d
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-19
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-v67w-737x-v2c9
- https://github.com/dlemstra/Magick.NET/releases/tag/14.12.0
Get alerted when CVE-2026-33900 or the next vulnerability affects your stack