What’s Vulnerable › Vulnerabilities
CVE-2026-33902: ImageMagick: Stack Overflow via Recursive FX Expression Parsing
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-13 · updated 2026-06-17
- Weakness: CWE-674
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. In versions below both 7.1.2-19 and 6.9.13-44, a stack overflow vulnerability in ImageMagick's FX expression parser allows an attacker to crash the process by providing a deeply nested expression. This issue has been fixed in versions 6.9.13-44 and 7.1.2-19.
Affected products
- ImageMagick: before 6.9.13-44; from 7.0.0-0 before 7.1.2-19 — fixed in 6.9.13-44, 7.1.2-19
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-44, 7.1.2-19. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/d3c0a37485314c5ccef72efb18f3847cd53868ba
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-f4qm-vj5j-9xpw
- https://github.com/dlemstra/Magick.NET/releases/tag/14.12.0
Get alerted when CVE-2026-33902 or the next vulnerability affects your stack