What’s Vulnerable › Vulnerabilities
CVE-2026-33908: ImageMagick is vulnerable to Stack Overflow in DestroyXMLTree()
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-13 · updated 2026-07-15
- Weakness: CWE-674
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. In versions below both 7.1.2-19 and 6.9.13-44, Magick frees the memory of the XML tree via the `DestroyXMLTree()` function; however, this process is executed recursively with no depth limit imposed. When Magick processes an XML file with deeply nested structures, it will exhaust the stack memory, resulting in a Denial of Service (DoS) attack. This issue has been fixed in versions 6.9.13-44 and 7.1.2-19.
Affected products
- ImageMagick: before 6.9.13-44; from 7.0.0-0 before 7.1.2-19 — fixed in 6.9.13-44, 7.1.2-19
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-44, 7.1.2-19. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/ccdc01180276aa2cb3d4a32a611aa4f417061cd8
- https://github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-19
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-fwvm-ggf6-2p4x
- https://github.com/dlemstra/Magick.NET/releases/tag/14.12.0
- https://access.redhat.com/security/cve/CVE-2026-33908
- https://bugzilla.redhat.com/show_bug.cgi?id=2458041
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33908.json
Get alerted when CVE-2026-33908 or the next vulnerability affects your stack