What’s Vulnerable › Vulnerabilities
CVE-2026-33911: OpenEMR vulnerable to reflected XSS in graphs.php via title parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Prior to version 8.0.0.3, the POST parameter `title` is reflected back in a JSON response built with `json_encode()`. Because the response is served with a `text/html` Content-Type, the browser interprets injected HTML/script tags rather than treating the output as JSON. An authenticated attacker can craft a request that executes arbitrary JavaScript in a victim's session. Version 8.0.0.3 contains a fix.
Affected products
- openemr: before 8.0.0.3 — fixed in 8.0.0.3
How to fix
Upgrade to a fixed version: openemr 8.0.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/64e8befa0a49f85dd5e2a85c91f3f8b9e565896f
- https://github.com/openemr/openemr/releases/tag/v8_0_0_3
- https://github.com/openemr/openemr/security/advisories/GHSA-wwhf-6cvc-6766
Get alerted when CVE-2026-33911 or the next vulnerability affects your stack