What’s Vulnerable › Vulnerabilities
CVE-2026-33912: OpenEMR has reflected XSS in ajax_download.php via reportID parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Prior to version 8.0.0.3, an authenticated attacker could craft a malicious form that, when submitted by a victim, executes arbitrary JavaScript in the victim's browser session. Version 8.0.0.3 patches the issue.
Affected products
- openemr: before 8.0.0.3 — fixed in 8.0.0.3
How to fix
Upgrade to a fixed version: openemr 8.0.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/24dd47c3e4936a6ddd064924d17b0273c6ac4b66
- https://github.com/openemr/openemr/commit/ae2a9e5edb8c88b9b0dff5969fd3aa98225f047e
- https://github.com/openemr/openemr/releases/tag/v8_0_0_3
- https://github.com/openemr/openemr/security/advisories/GHSA-cpph-949w-w79v
Get alerted when CVE-2026-33912 or the next vulnerability affects your stack