What’s Vulnerable › Vulnerabilities
CVE-2026-33924: Authenticated RCE in update functionality in Guardian/CMC before 26.4.0
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-29 · updated 2026-10-29
- Weakness: CWE-78
Description
Two OS command injection vulnerabilities were discovered in the update installation functionality due to insufficient validation of the update bundle contents. An attacker with administrative privileges can remotely supply a crafted update bundle that, when installed, causes arbitrary commands to be executed with root privileges, allowing the attacker to read or modify sensitive data, change the appliance configuration, or shut down the appliance.
Affected products
- Nozomi Networks CMC: before 26.4.0 — fixed in 26.4.0
- Nozomi Networks Guardian: before 26.4.0 — fixed in 26.4.0
How to fix
Upgrade to a fixed version: Nozomi Networks CMC 26.4.0; Nozomi Networks Guardian 26.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-33924 or the next vulnerability affects your stack