What’s Vulnerable › Vulnerabilities
CVE-2026-33933: Reflected XSS via Unescaped contextName Parameter in Custom Template Editor
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-26 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Starting in version 7.0.2.1 and prior to version 8.0.0.3, a reflected cross-site scripting (XSS) vulnerability in the custom template editor allows an attacker to execute arbitrary JavaScript in an authenticated staff member's browser session by sending them a crafted URL. The attacker does not need an OpenEMR account. Version 8.0.0.3 patches the issue.
Affected products
- openemr: from 7.0.2.1 before 8.0.0.3 — fixed in 8.0.0.3
How to fix
Upgrade to a fixed version: openemr 8.0.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/d5c8d49ef19983472b2d7db0dbebd2dac9d6a200
- https://github.com/openemr/openemr/commit/de9b6eb0da574430e8223c014cf4a05b0adc29d8
- https://github.com/openemr/openemr/releases/tag/v8_0_0_3
- https://github.com/openemr/openemr/security/advisories/GHSA-9qh7-cfq4-j7c3
- https://github.com/openemr/openemr/security/advisories/GHSA-9qh7-cfq4-j7c3
Get alerted when CVE-2026-33933 or the next vulnerability affects your stack