What’s Vulnerable › Vulnerabilities
CVE-2026-33937: Handlebars.js has JavaScript Injection via AST Type Confusion
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-27 · updated 2026-10-26
- Weakness: CWE-94
Description
Handlebars provides the power necessary to let users build semantic templates. In versions 4.0.0 through 4.7.8, `Handlebars.compile()` accepts a pre-parsed AST object in addition to a template string. The `value` field of a `NumberLiteral` AST node is emitted directly into the generated JavaScript without quoting or sanitization. An attacker who can supply a crafted AST to `compile()` can therefore inject and execute arbitrary JavaScript, leading to Remote Code Execution on the server. Version 4.7.9 fixes the issue. Some workarounds are available. Validate input type before calling `Handlebars.compile()`; ensure the argument is always a `string`, never a plain object or JSON-deserialized value. Use the Handlebars runtime-only build (`handlebars/runtime`) on the server if templates are pre-compiled at build time; `compile()` will be unavailable.
Affected products
- handlebars-lang handlebars.js: from 4.0.0 before 4.7.9 — fixed in 4.7.9
- Npm Handlebars: from 4.0.0 before 4.7.9 — fixed in 4.7.9
How to fix
Upgrade to a fixed version: handlebars-lang handlebars.js 4.7.9; Npm Handlebars 4.7.9. Check the vendor advisory for mitigations.
References
- https://github.com/handlebars-lang/handlebars.js/commit/68d8df5a88e0a26fe9e6084c5c6aaebe67b07da2
- https://github.com/handlebars-lang/handlebars.js/releases/tag/v4.7.9
- https://github.com/handlebars-lang/handlebars.js/security/advisories/GHSA-2w6w-674q-4c4q
- https://access.redhat.com/errata/RHSA-2026:10175
- https://access.redhat.com/errata/RHSA-2026:34342
- https://access.redhat.com/security/cve/CVE-2026-33937
- https://bugzilla.redhat.com/show_bug.cgi?id=2452523
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33937.json
Get alerted when CVE-2026-33937 or the next vulnerability affects your stack