What’s Vulnerable › Vulnerabilities
CVE-2026-33997: Moby: Off-by-one error in plugin privilege validation
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-09-09
- Weakness: CWE-193
Description
Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows plugins privilege validation to be bypassed during docker plugin install. Due to an error in the daemon's privilege comparison logic, the daemon may incorrectly accept a privilege set that differs from the one approved by the user. Plugins that request exactly one privilege are also affected, because no comparison is performed at all. This issue has been patched in version 29.3.1.
Affected products
- Docker Engine: before 29.3.1 — fixed in 29.3.1
How to fix
Upgrade to a fixed version: Docker Engine 29.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/moby/moby/releases/tag/docker-v29.3.1
- https://github.com/moby/moby/security/advisories/GHSA-pxq6-2prw-chj9
- https://access.redhat.com/errata/RHSA-2026:21769
- https://access.redhat.com/errata/RHSA-2026:22347
- https://access.redhat.com/errata/RHSA-2026:23345
- https://access.redhat.com/security/cve/CVE-2026-33997
- https://bugzilla.redhat.com/show_bug.cgi?id=2453277
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33997.json
Get alerted when CVE-2026-33997 or the next vulnerability affects your stack