What’s Vulnerable › Vulnerabilities
CVE-2026-34032: Apache HTTP Server: mod_proxy_ajp: Heap Buffer Over-Read Due to Missing Null-Termination Check (ajp_msg_get_string)
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-04 · updated 2026-10-26
- Weakness: CWE-125
Description
Improper Null Termination, Out-of-bounds Read vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.
Affected products
- Apache HTTP Server: before 2.4.67 — fixed in 2.4.67
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.67. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2026/05/04/16
Get alerted when CVE-2026-34032 or the next vulnerability affects your stack