What’s Vulnerable › Vulnerabilities
CVE-2026-34052: LTI JupyterHub Authenticator: Unbounded Memory Growth via Nonce Storage (Denial of Service)
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-03 · updated 2026-07-24
- Weakness: CWE-401
Description
LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.
Affected products
- jupyter Lti Jupyterhub Authenticator: before 1.6.3 — fixed in 1.6.3
How to fix
Upgrade to a fixed version: jupyter Lti Jupyterhub Authenticator 1.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/jupyterhub/ltiauthenticator/releases/tag/1.6.3
- https://github.com/jupyterhub/ltiauthenticator/security/advisories/GHSA-8mxq-7xr7-2fxj
Get alerted when CVE-2026-34052 or the next vulnerability affects your stack