What’s Vulnerable › Vulnerabilities
CVE-2026-34060: Ruby LSP has arbitrary code execution through branch setting
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-06-17
- Weakness: CWE-94
Description
Ruby LSP is an implementation of the language server protocol for Ruby. Prior to Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9, the rubyLsp.branch VS Code workspace setting was interpolated without sanitization into a generated Gemfile, allowing arbitrary Ruby code execution when a user opens a project containing a malicious .vscode/settings.json. This issue has been patched in Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9.
Affected products
- Shopify Ruby Lsp: before 0.10.2; before 0.26.9 — fixed in 0.10.2, 0.26.9
How to fix
Upgrade to a fixed version: Shopify Ruby Lsp 0.10.2, 0.26.9. Check the vendor advisory for mitigations.
References
- https://github.com/Shopify/ruby-lsp/releases/tag/v0.26.9
- https://github.com/Shopify/ruby-lsp/security/advisories/GHSA-c4r5-fxqw-vh93
Get alerted when CVE-2026-34060 or the next vulnerability affects your stack