What’s Vulnerable › Vulnerabilities
CVE-2026-34065: nimiq-primitives: Node crash due to missing interlink validation in election macro block proposals
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-22 · updated 2026-10-26
- Weakness: CWE-252
Description
nimiq-primitives contains primitives (e.g., block, account, transaction) to be used in Nimiq's Rust implementation. Prior to version 1.3.0, an untrusted p2p peer can cause a node to panic by announcing an election macro block whose `validators` set contains an invalid compressed BLS voting key. Hashing an election macro header hashes `validators` and reaches `Validators::voting_keys()`, which calls `validator.voting_key.uncompress().unwrap()` and panics on invalid bytes. The patch for this vulnerability is included as part of v1.3.0. No known workarounds are available.
Affected products
- nimiq-transaction: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: nimiq-transaction 1.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/nimiq/core-rs-albatross/commit/e10eaebcd7774e5da6d0ff5e88ed13503474f0ff
- https://github.com/nimiq/core-rs-albatross/pull/3662
- https://github.com/nimiq/core-rs-albatross/releases/tag/v1.3.0
- https://github.com/nimiq/core-rs-albatross/security/advisories/GHSA-7c4j-2m43-2mgh
Get alerted when CVE-2026-34065 or the next vulnerability affects your stack