What’s Vulnerable › Vulnerabilities
CVE-2026-34070: LangChain Core has Path Traversal vulnerabilites in legacy `load_prompt` functions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-31 · updated 2026-08-25
- Weakness: CWE-22
Description
LangChain is a framework for building agents and LLM-powered applications. Prior to version 1.2.22, multiple functions in langchain_core.prompts.loading read files from paths embedded in deserialized config dicts without validating against directory traversal or absolute path injection. When an application passes user-influenced prompt configurations to load_prompt() or load_prompt_from_config(), an attacker can read arbitrary files on the host filesystem, constrained only by file-extension checks (.txt for templates, .json/.yaml for examples). This issue has been patched in version 1.2.22.
Affected products
- langchain-ai langchain: before 1.2.22 — fixed in 1.2.22
How to fix
Upgrade to a fixed version: langchain-ai langchain 1.2.22. Check the vendor advisory for mitigations.
References
- https://github.com/langchain-ai/langchain/commit/27add913474e01e33bededf4096151130ba0d47c
- https://github.com/langchain-ai/langchain/releases/tag/langchain-core==1.2.22
- https://github.com/langchain-ai/langchain/security/advisories/GHSA-qh6h-p6c9-ff54
- https://access.redhat.com/errata/RHSA-2026:24766
- https://access.redhat.com/errata/RHSA-2026:37275
- https://access.redhat.com/errata/RHSA-2026:59159
- https://access.redhat.com/security/cve/CVE-2026-34070
- https://bugzilla.redhat.com/show_bug.cgi?id=2453287
- https://github.com/langchain-ai/langchain/security/advisories/GHSA-qh6h-p6c9-ff54
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-34070.json
Get alerted when CVE-2026-34070 or the next vulnerability affects your stack