What’s Vulnerable › Vulnerabilities

CVE-2026-34077: React Router vulnerable to Denial of Service via reflected user input in single-fetch

Description

React Router is a router for React. In versions 7.7.0 through 7.13.1, when using React Router's unstable React Server Components (RSC) APIs, there is a potential client-side Cross-Site Scripting (XSS) vulnerability in the RSC redirect handling if redirects come from untrusted sources. This does not impact applications that are not using the unstable RSC APIs in React Router. This is patched in version 7.13.2.

Affected products

How to fix

Upgrade to a fixed version: remix-run react-router 7.14.0; Turbo-Stream Turbo Stream 3.0.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-34077 or the next vulnerability affects your stack