What’s Vulnerable › Vulnerabilities
CVE-2026-34084: PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-05 · updated 2026-07-24
- Weakness: CWE-502
Description
PhpSpreadsheet is a library for reading and writing spreadsheet files. In versions 1.30.2 and earlier, 2.0.0 through 2.1.14, 2.2.0 through 2.4.3, 3.3.0 through 3.10.3, and 4.0.0 through 5.5.0, when the filename argument to IOFactory::load() is user-controlled, an attacker can supply a PHP stream wrapper path (such as phar://, ftp://, or ssh2.sftp://) that passes the is_file() check in File::assertFile(). The phar:// wrapper triggers deserialization of the PHAR metadata, which can lead to remote code execution if a suitable gadget chain is available in the application. The ftp:// and ssh2.sftp:// wrappers can be used for server-side request forgery. This issue has been fixed in versions 1.30.3, 2.1.15, 2.4.4, 3.10.4, and 5.6.0.
Affected products
- PHPOffice PhpSpreadsheet: before 1.30.3; from 2.0.0 before 2.1.15; from 2.2.0 before 2.4.4; from 3.3.0 before 3.10.4; from 4.0.0 before 5.6.0 — fixed in 1.30.3, 2.1.15, 2.4.4, 3.10.4, 5.6.0
How to fix
Upgrade to a fixed version: PHPOffice PhpSpreadsheet 1.30.3, 2.1.15, 2.4.4, 3.10.4. Check the vendor advisory for mitigations.
References
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-q4q6-r8wh-5cgh
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-q4q6-r8wh-5cgh
Get alerted when CVE-2026-34084 or the next vulnerability affects your stack