What’s Vulnerable › Vulnerabilities
CVE-2026-34088: RecentChanges entries expose suppressed content via generated log page html
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-10-26
- Weakness: CWE-200
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki. This issue affects MediaWiki: from * before 1.43.7, 1.44.4, 1.45.2.
Affected products
- Wikimedia Foundation MediaWiki: before 1.43.7; from 1.44.0 before 1.44.4; from 1.45.0 before 1.45.2 — fixed in 1.43.7, 1.44.4, 1.45.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.43.7, 1.44.4, 1.45.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34088 or the next vulnerability affects your stack