What’s Vulnerable › Vulnerabilities
CVE-2026-34148: Fedify affected by resource exhaustion caused by unbounded redirect following during remote key/document resolution
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-06 · updated 2026-10-26
- Weakness: CWE-400
Description
Fedify is a TypeScript library for building federated server apps powered by ActivityPub. Prior to 1.9.6, 1.10.5, 2.0.8, and 2.1.1, @fedify/fedify follows HTTP redirects recursively in its remote document loader and authenticated document loader without enforcing a maximum redirect count or visited-URL loop detection. An attacker who controls a remote ActivityPub key or actor URL can force a server using Fedify to make repeated outbound requests from a single inbound request, leading to resource consumption and denial of service. This vulnerability is fixed in 1.9.6, 1.10.5, 2.0.8, and 2.1.1.
Affected products
- @fedify Fedify/Fedify: before 1.9.6; from 1.10.0 before 1.10.5; from 2.0.0 before 2.0.8; from 2.1.0 before 2.1.1 — fixed in 1.9.6, 1.10.5, 2.0.8, 2.1.1
- @fedify Fedify/Vocab-Runtime: before 2.0.8; from 2.1.0 before 2.1.1 — fixed in 2.0.8, 2.1.1
How to fix
Upgrade to a fixed version: @fedify Fedify/Fedify 1.9.6, 1.10.5, 2.0.8, 2.1.1; @fedify Fedify/Vocab-Runtime 2.0.8, 2.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/fedify-dev/fedify/releases/tag/1.10.5
- https://github.com/fedify-dev/fedify/releases/tag/1.9.6
- https://github.com/fedify-dev/fedify/releases/tag/2.0.8
- https://github.com/fedify-dev/fedify/releases/tag/2.1.1
- https://github.com/fedify-dev/fedify/security/advisories/GHSA-gm9m-gwc4-hwgp
- https://github.com/fedify-dev/fedify/security/advisories/GHSA-gm9m-gwc4-hwgp
Get alerted when CVE-2026-34148 or the next vulnerability affects your stack