What’s Vulnerable › Vulnerabilities
CVE-2026-34154: Discourse has a subscription access bypass in its discourse-subscriptions plugin
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-19 · updated 2026-07-24
- Weakness: CWE-862
Description
Discourse is an open-source discussion platform. In versions prior to 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1, a vulnerability in the discourse-subscriptions plugin allows users to gain access to subscription-gated groups without completing payment. This issue has been fixed in versions 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1.
Affected products
- discourse: from 2026.1.0 before 2026.1.4; from 2026.3.0 before 2026.3.1; from 2026.4.0 before 2026.4.1; 2026.5.0 — fixed in 2026.1.4, 2026.3.1, 2026.4.1
How to fix
Upgrade to a fixed version: discourse 2026.1.4, 2026.3.1, 2026.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34154 or the next vulnerability affects your stack