What’s Vulnerable › Vulnerabilities
CVE-2026-34197: Apache ActiveMQ Improper Input Validation Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-04-16
- EPSS: 98.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-07 · updated 2026-10-26
- Weakness: CWE-20
Description
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ. Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ All: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.3. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue
Affected products
- Apache ActiveMQ: before 5.19.4; from 6.0.0 before 6.2.3 — fixed in 5.19.4, 6.2.3
- Apache Activemq Broker: before 5.19.4; from 6.0.0 before 6.2.3 — fixed in 5.19.4, 6.2.3
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.19.4, 6.2.3; Apache Activemq Broker 5.19.4, 6.2.3. Check the vendor advisory for mitigations.
References
- https://activemq.apache.org/security-advisories.data/CVE-2026-34197-announcement.txt
- http://www.openwall.com/lists/oss-security/2026/04/06/3
- https://access.redhat.com/security/cve/CVE-2026-34197
- https://bugzilla.redhat.com/show_bug.cgi?id=2455869
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-34197.json
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-34197
Get alerted when CVE-2026-34197 or the next vulnerability affects your stack