What’s Vulnerable › Vulnerabilities
CVE-2026-34211: SandboxJS: Stack overflow DoS via deeply nested expressions in recursive descent parser
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-06 · updated 2026-10-26
- Weakness: CWE-674
Description
SandboxJS is a JavaScript sandboxing library. Prior to 0.8.36, the @nyariv/sandboxjs parser contains unbounded recursion in the restOfExp function and the lispify/lispifyExpr call chain. An attacker can crash any Node.js process that parses untrusted input by supplying deeply nested expressions (e.g., ~2000 nested parentheses), causing a RangeError: Maximum call stack size exceeded that terminates the process. This vulnerability is fixed in 0.8.36.
Affected products
- nyariv SandboxJS: before 0.8.36 — fixed in 0.8.36
How to fix
Upgrade to a fixed version: nyariv SandboxJS 0.8.36. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34211 or the next vulnerability affects your stack