What’s Vulnerable › Vulnerabilities
CVE-2026-34213: Docmost has cross-page attachment overwrite via flawed attachmentId overwrite validation
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-14 · updated 2026-07-24
- Weakness: CWE-639
Description
Docmost is open-source collaborative wiki and documentation software. Starting in version 0.3.0 and prior to version 0.71.0, improper authorization in Docmost allows a low-privileged authenticated user to overwrite another page's attachment within the same workspace by supplying a victim `attachmentId` to `POST /api/files/upload`. This is a remote integrity issue requiring no victim interaction. Version 0.71.0 contains a patch.
Affected products
- docmost: from 0.3.0 before 0.71.0 — fixed in 0.71.0
How to fix
Upgrade to a fixed version: docmost 0.71.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34213 or the next vulnerability affects your stack