What’s Vulnerable › Vulnerabilities
CVE-2026-34215: Parse Server: Auth data exposed via verify password endpoint
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-200
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.63 and 9.7.0-alpha.7, the verify password endpoint returns unsanitized authentication data, including MFA TOTP secrets, recovery codes, and OAuth access tokens. An attacker who knows a user's password can extract the MFA secret to generate valid MFA codes, defeating multi-factor authentication protection. This issue has been patched in versions 8.6.63 and 9.7.0-alpha.7.
Affected products
- parse-community parse-server: before 8.6.63; from 9.0.0 before 9.7.0; 9.7.0-alpha1, 9.7.0-alpha2, 9.7.0-alpha3, 9.7.0-alpha4, 9.7.0-alpha5, 9.7.0-alpha6 — fixed in 8.6.63, 9.7.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.63, 9.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/770be8647424d92f5425c41fa81065ffbbb171ed
- https://github.com/parse-community/parse-server/commit/a1d4e7b12a12f16d3870dbee582a36765858e94c
- https://github.com/parse-community/parse-server/pull/10323
- https://github.com/parse-community/parse-server/pull/10324
- https://github.com/parse-community/parse-server/security/advisories/GHSA-wp76-gg32-8258
Get alerted when CVE-2026-34215 or the next vulnerability affects your stack