What’s Vulnerable › Vulnerabilities
CVE-2026-34220: MikroORM is vulnerable to SQL Injection via specially crafted object
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-89
Description
MikroORM is a TypeScript ORM for Node.js based on Data Mapper, Unit of Work and Identity Map patterns. Prior to versions 6.6.10 and 7.0.6, there is a SQL injection vulnerability when specially crafted objects are interpreted as raw SQL query fragments. This issue has been patched in versions 6.6.10 and 7.0.6.
Affected products
- mikro-orm Mikroorm: before 6.6.10; from 7.0.0 before 7.0.6 — fixed in 6.6.10, 7.0.6
How to fix
Upgrade to a fixed version: mikro-orm Mikroorm 6.6.10, 7.0.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34220 or the next vulnerability affects your stack