What’s Vulnerable › Vulnerabilities
CVE-2026-34224: Parse Server: MFA single-use token bypass via concurrent authData login requests
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-367
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.64 and 9.7.0-alpha.8, an attacker who possesses a valid authentication provider token and a single MFA recovery code or SMS one-time password can create multiple authenticated sessions by sending concurrent login requests via the authData login endpoint. This defeats the single-use guarantee of MFA recovery codes and SMS one-time passwords, allowing session persistence even after the legitimate user revokes detected sessions. This issue has been patched in versions 8.6.64 and 9.7.0-alpha.8.
Affected products
- parse-community parse-server: before 8.6.64; from 9.0.0 before 9.7.0; 9.7.0-alpha1, 9.7.0-alpha2, 9.7.0-alpha3, 9.7.0-alpha4, 9.7.0-alpha5, 9.7.0-alpha6 (+1) — fixed in 8.6.64, 9.7.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.64, 9.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/661f160edac8daac0486bc94413cf9652876ab92
- https://github.com/parse-community/parse-server/commit/e7efbebba398ce6abe5b6b6fb9829c6ebe310fbf
- https://github.com/parse-community/parse-server/pull/10326
- https://github.com/parse-community/parse-server/pull/10327
- https://github.com/parse-community/parse-server/security/advisories/GHSA-w73w-g5xw-rwhf
Get alerted when CVE-2026-34224 or the next vulnerability affects your stack