What’s Vulnerable › Vulnerabilities
CVE-2026-34373: Parse Server: GraphQL API endpoint ignores CORS origin restriction
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-346
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.66 and 9.7.0-alpha.10, the GraphQL API endpoint does not respect the allowOrigin server option and unconditionally allows cross-origin requests from any website. This bypasses origin restrictions that operators configure to control which websites can interact with the Parse Server API. The REST API correctly enforces the configured allowOrigin restriction. This issue has been patched in versions 8.6.66 and 9.7.0-alpha.10.
Affected products
- parse-community parse-server: from 3.5.0 before 8.6.66; from 9.0.0 before 9.7.0; 9.7.0-alpha1, 9.7.0-alpha2, 9.7.0-alpha3, 9.7.0-alpha4, 9.7.0-alpha5, 9.7.0-alpha6 (+3) — fixed in 8.6.66, 9.7.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.66, 9.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/0347641507891d0013ec57f7c10f012064f41263
- https://github.com/parse-community/parse-server/commit/4dd0d3d8be1c39664c74ad10bb0abaa76bc41203
- https://github.com/parse-community/parse-server/pull/10334
- https://github.com/parse-community/parse-server/pull/10335
- https://github.com/parse-community/parse-server/security/advisories/GHSA-q3p6-g7c4-829c
Get alerted when CVE-2026-34373 or the next vulnerability affects your stack