What’s Vulnerable › Vulnerabilities
CVE-2026-34386: Fleet vulnerable to SQL injection in MDM bootstrap package by authenticated team or global admin
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-27 · updated 2026-10-26
- Weakness: CWE-89
Description
Fleet is open source device management software. Prior to 4.81.0, a SQL injection vulnerability in Fleet's MDM bootstrap package configuration allows an authenticated user with Team Admin or Global Admin privileges to modify arbitrary team configurations, exfiltrate sensitive data from the Fleet database, and inject arbitrary content into team configs via direct API calls. Version 4.81.0 patches the issue.
Affected products
- fleetdm fleet: before 4.81.0 — fixed in 4.81.0
How to fix
Upgrade to a fixed version: fleetdm fleet 4.81.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34386 or the next vulnerability affects your stack