What’s Vulnerable › Vulnerabilities
CVE-2026-34387: Fleet vulnerable to OS command injection via crafted software package metadata in uninstall scripts
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-27 · updated 2026-10-26
- Weakness: CWE-78
Description
Fleet is open source device management software. Prior to 4.81.1, a command injection vulnerability in Fleet's software installer pipeline allows an attacker to achieve arbitrary code execution as root (macOS/Linux) or SYSTEM (Windows) on managed hosts when an uninstall is triggered for a crafted software package. Version 4.81.1 patches the issue.
Affected products
- fleetdm fleet: before 4.81.1 — fixed in 4.81.1
How to fix
Upgrade to a fixed version: fleetdm fleet 4.81.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34387 or the next vulnerability affects your stack