What’s Vulnerable › Vulnerabilities
CVE-2026-34388: Fleet vulnerable to Denial of Service via unhandled gRPC log type in launcher endpoint
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-27 · updated 2026-10-26
- Weakness: CWE-703
Description
Fleet is open source device management software. Prior to 4.81.0, a denial-of-service vulnerability in Fleet's gRPC Launcher endpoint allows an authenticated host to crash the entire Fleet server process by sending an unexpected log type value. The server terminates immediately, disrupting all connected hosts, MDM enrollments, and API consumers. Version 4.81.0 patches the issue.
Affected products
- fleetdm fleet: before 4.81.0 — fixed in 4.81.0
How to fix
Upgrade to a fixed version: fleetdm fleet 4.81.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34388 or the next vulnerability affects your stack