What’s Vulnerable › Vulnerabilities
CVE-2026-34393: Weblate: Privilege escalation in the user API endpoint
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-15 · updated 2026-10-26
- Weakness: CWE-269
Description
Weblate is a web based localization tool. In versions prior to 5.17, the user patching API endpoint didn't properly limit the scope of edits. This issue has been fixed in version 5.17.
Affected products
- WeblateOrg weblate: before 5.17 — fixed in 5.17
How to fix
Upgrade to a fixed version: WeblateOrg weblate 5.17. Check the vendor advisory for mitigations.
References
- https://github.com/WeblateOrg/weblate/pull/18687
- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-3382-gw9x-477v
Get alerted when CVE-2026-34393 or the next vulnerability affects your stack