What’s Vulnerable › Vulnerabilities
CVE-2026-34400: alerta-server has potential SQL Injection vulnerability in Query String Syntax (q=) API
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-89
Description
Alerta is a monitoring tool. Prior to version 9.1.0, the Query string search API (q=) was vulnerable to SQL injection via the Postgres query parser, which built WHERE clauses by interpolating user-supplied search terms directly into SQL strings via f-strings. This issue has been patched in version 9.1.0.
Affected products
- alerta: before 9.1.0 — fixed in 9.1.0
How to fix
Upgrade to a fixed version: alerta 9.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/alerta/alerta/commit/aeba85a37a09e5769a7a2da56481aa979ff99a00
- https://github.com/alerta/alerta/commit/fdd52cd1abad8d02d1dfb8ecdcdbb43b6af3b883
- https://github.com/alerta/alerta/pull/2040
- https://github.com/alerta/alerta/pull/712
- https://github.com/alerta/alerta/releases/tag/v9.1.0
- https://github.com/alerta/alerta/security/advisories/GHSA-8prr-286p-4w7j
Get alerted when CVE-2026-34400 or the next vulnerability affects your stack