What’s Vulnerable › Vulnerabilities
CVE-2026-34403: Nginx-UI vulnerable to Cross-Site WebSocket Hijacking (CSWSH) via missing origin validation on all WebSocket endpoints
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-20 · updated 2026-10-26
- Weakness: CWE-1385
Description
Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.5, all WebSocket endpoints in nginx-ui use a gorilla/websocket Upgrader with CheckOrigin unconditionally returning true, allowing Cross-Site WebSocket Hijacking (CSWSH). Combined with the fact that authentication tokens are stored in browser cookies (set via JavaScript without HttpOnly or explicit SameSite attributes), a malicious webpage can establish authenticated WebSocket connections to the nginx-ui instance when a logged-in administrator visits the attacker-controlled page. Version 2.3.5 patches the issue.
Affected products
- 0xJacky nginx-ui: before 2.3.5 — fixed in 2.3.5
How to fix
Upgrade to a fixed version: 0xJacky nginx-ui 2.3.5. Check the vendor advisory for mitigations.
References
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.5
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-78mf-482w-62qj
Get alerted when CVE-2026-34403 or the next vulnerability affects your stack