What’s Vulnerable › Vulnerabilities
CVE-2026-34406: APTRS: Privilege Escalation via Mass Assignment of is_superuser in User Edit Endpoint
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-915
Description
APTRS (Automated Penetration Testing Reporting System) is a Python and Django-based automated reporting tool designed for penetration testers and security organizations. Prior to version 2.0.1, the edit_user endpoint (POST /api/auth/edituser/<pk>) allows Any user who can reach that endpoint and submit crafted permission to escalate their own account (or any other account) to superuser by including "is_superuser": true in the request body. The root cause is that CustomUserSerializer explicitly includes is_superuser in its fields list but omits it from read_only_fields, making it a writable field. The edit_user view performs no additional validation to prevent non-superusers from modifying this field. Once is_superuser is set to true, gaining unrestricted access to all application functionality without requiring re-authentication. This issue has been patched in version 2.0.1.
Affected products
- APTRS: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: APTRS 2.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/APTRS/APTRS/commit/d1f1b3a5d1953082af8e075712ca29742e900d56
- https://github.com/APTRS/APTRS/releases/tag/2.0.1
- https://github.com/APTRS/APTRS/security/advisories/GHSA-gv25-wp4h-9c35
Get alerted when CVE-2026-34406 or the next vulnerability affects your stack