What’s Vulnerable › Vulnerabilities
CVE-2026-34425: OpenClaw - Shell-Bleed Protection Preflight Validation Bypass
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-02 · updated 2026-07-24
- Weakness: CWE-184
Description
OpenClaw versions prior to commit 8aceaf5 contain a preflight validation bypass vulnerability in shell-bleed protection that allows attackers to execute blocked script content by using piped or complex command forms that the parser fails to recognize. Attackers can craft commands such as piped execution, command substitution, or subshell invocation to bypass the validateScriptFileForShellBleed() validation checks and execute arbitrary script content that would otherwise be blocked.
Affected products
- OpenClaw: before 2026.4.2 — fixed in 2026.4.2
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/8aceaf5d0f0ec552b75a792f7f0a3bfa5b091513
- https://github.com/openclaw/openclaw/security/advisories/GHSA-fvx6-pj3r-5q4q
- https://www.vulncheck.com/advisories/openclaw-shell-bleed-protection-preflight-validation-bypass
Get alerted when CVE-2026-34425 or the next vulnerability affects your stack