What’s Vulnerable › Vulnerabilities
CVE-2026-34475
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-27 · updated 2026-10-26
- Weakness: CWE-180
Description
Varnish Cache before 8.0.1 and Varnish Enterprise before 6.0.16r12, in certain unchecked req.url scenarios, mishandle URLs with a path of / for HTTP/1.1, potentially leading to cache poisoning or authentication bypass.
Affected products
- varnish-software Varnish Enterprise: through 6.0.15; 6.0.16-r1, 6.0.16-r10, 6.0.16-r11, 6.0.16-r2, 6.0.16-r3, 6.0.16-r4 (+5)
- varnish-software Varnish Cache: before 8.0.1 — fixed in 8.0.1
How to fix
Upgrade to a fixed version: varnish-software Varnish Cache 8.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34475 or the next vulnerability affects your stack