What’s Vulnerable › Vulnerabilities
CVE-2026-34491
- Severity: medium (CVSS 6.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-24 · updated 2026-10-14
- Weakness: CWE-79
Description
Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Johnson Controls Metasys 14 and Johnson Controls Metasys 15 allows Cross Site Scripting. This issue affects Metasys 14: before 14.1.5; Metasys 15: before 15.0.1.
Affected products
- Johnson Controls Metasys 14: before 14.1.5 — fixed in 14.1.5
- Johnson Controls Metasys 15: before 15.0.1 — fixed in 15.0.1
How to fix
Upgrade to a fixed version: Johnson Controls Metasys 14 14.1.5; Johnson Controls Metasys 15 15.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34491 or the next vulnerability affects your stack