What’s Vulnerable › Vulnerabilities
CVE-2026-34501: Apache Portable Runtime Utility: Heap buffer overflow in APR redis client
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-10-24
- Weakness: CWE-122
Description
Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility redis client. This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3. Users are recommended to upgrade to version 1.6.4, which fixes the issue.
Affected products
- Apache Apr-Util: from 1.6.0 before 1.6.4 — fixed in 1.6.4
How to fix
Upgrade to a fixed version: Apache Apr-Util 1.6.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/o8h6c7cq86fplxlnry6c3rn9x0ovq8mv
- http://www.openwall.com/lists/oss-security/2026/08/06/11
Get alerted when CVE-2026-34501 or the next vulnerability affects your stack