What’s Vulnerable › Vulnerabilities
CVE-2026-34524: SillyTavern: Path traversal in `/api/chats/export` and `/api/chats/delete` allows arbitrary file read/delete within user data root
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-02 · updated 2026-07-24
- Weakness: CWE-22
Description
SillyTavern is a locally installed user interface that allows users to interact with text generation large language models, image generation engines, and text-to-speech voice models. Prior to version 1.17.0, a path traversal vulnerability in chat endpoints allows an authenticated attacker to read and delete arbitrary files under their user data root (for example secrets.json and settings.json) by supplying avatar_url="..". This issue has been patched in version 1.17.0.
Affected products
- SillyTavern: before 1.17.0 — fixed in 1.17.0
How to fix
Upgrade to a fixed version: SillyTavern 1.17.0. Check the vendor advisory for mitigations.
References
- https://github.com/SillyTavern/SillyTavern/releases/tag/1.17.0
- https://github.com/SillyTavern/SillyTavern/security/advisories/GHSA-vprr-q85p-79mf
- https://github.com/SillyTavern/SillyTavern/security/advisories/GHSA-vprr-q85p-79mf
Get alerted when CVE-2026-34524 or the next vulnerability affects your stack