What’s Vulnerable › Vulnerabilities
CVE-2026-3455
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Versions of the package mailparser before 3.9.3 are vulnerable to Cross-site Scripting (XSS) via the textToHtml() function due to the improper sanitisation of URLs in the email content. An attacker can execute arbitrary scripts in victim browsers by adding extra quote " to the URL with embedded malicious JavaScript code.
Affected products
- mailparser: before 3.9.3 — fixed in 3.9.3
How to fix
Upgrade to a fixed version: mailparser 3.9.3. Check the vendor advisory for mitigations.
References
- https://gist.github.com/hayageek/7fcb225e3b1ea9a341d560403fbb585a
- https://github.com/nodemailer/mailparser/commit/921a67df4cfb38f0b411037d7b26fbd4d5411b08
- https://github.com/nodemailer/mailparser/issues/412
- https://security.snyk.io/vuln/SNYK-JS-MAILPARSER-15204032
Get alerted when CVE-2026-3455 or the next vulnerability affects your stack