What’s Vulnerable › Vulnerabilities
CVE-2026-34568: CI4MS: Blogs Posts Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-01 · updated 2026-10-26
- Weakness: CWE-79
Description
CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.31.0.0, the application fails to properly sanitize user-controlled input when creating or editing blog posts. An attacker can inject a malicious JavaScript payload into blog post content, which is then stored server-side. This stored payload is later rendered unsafely in multiple application views without proper output encoding, leading to stored cross-site scripting (XSS). This issue has been patched in version 0.31.0.0.
Affected products
- ci4-cms-erp ci4ms: before 0.31.0.0 — fixed in 0.31.0.0
How to fix
Upgrade to a fixed version: ci4-cms-erp ci4ms 0.31.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/ci4-cms-erp/ci4ms/releases/tag/0.31.0.0
- https://github.com/ci4-cms-erp/ci4ms/security/advisories/GHSA-x7wh-g25g-53vg
- https://github.com/ci4-cms-erp/ci4ms/security/advisories/GHSA-x7wh-g25g-53vg
Get alerted when CVE-2026-34568 or the next vulnerability affects your stack