What’s Vulnerable › Vulnerabilities
CVE-2026-34571: CI4MS: Stored Cross‑Site Scripting (Stored XSS) in Backend User Management Allows Session Hijacking and Full Administrative Account Compromise
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-01 · updated 2026-10-26
- Weakness: CWE-79
Description
CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.31.0.0, a Stored Cross-Site Scripting (Stored XSS) vulnerability exists in the backend user management functionality. The application fails to properly sanitize user-controlled input before rendering it in the administrative interface, allowing attackers to inject persistent JavaScript code. This results in automatic execution whenever backend users access the affected page, enabling session hijacking, privilege escalation, and full administrative account compromise. This issue has been patched in version 0.31.0.0.
Affected products
- ci4-cms-erp ci4ms: before 0.31.0.0 — fixed in 0.31.0.0
How to fix
Upgrade to a fixed version: ci4-cms-erp ci4ms 0.31.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/ci4-cms-erp/ci4ms/releases/tag/0.31.0.0
- https://github.com/ci4-cms-erp/ci4ms/security/advisories/GHSA-fc4p-p49v-r948
- https://github.com/ci4-cms-erp/ci4ms/security/advisories/GHSA-fc4p-p49v-r948
Get alerted when CVE-2026-34571 or the next vulnerability affects your stack