What’s Vulnerable › Vulnerabilities
CVE-2026-34573: Parse Server: GraphQL complexity validator exponential fragment traversal DoS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-407
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.68 and 9.7.0-alpha.12, the GraphQL query complexity validator can be exploited to cause a denial-of-service by sending a crafted query with binary fan-out fragment spreads. A single unauthenticated request can block the Node.js event loop for seconds, denying service to all concurrent users. This only affects deployments that have enabled the requestComplexity.graphQLDepth or requestComplexity.graphQLFields configuration options. This issue has been patched in versions 8.6.68 and 9.7.0-alpha.12.
Affected products
- parse-community parse-server: before 8.6.68; from 9.0.0 before 9.7.0; 9.7.0-alpha1, 9.7.0-alpha10, 9.7.0-alpha11, 9.7.0-alpha2, 9.7.0-alpha3, 9.7.0-alpha4 (+5) — fixed in 8.6.68, 9.7.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.68, 9.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/ea15412795f34594cc8a674fe858d445675e0295
- https://github.com/parse-community/parse-server/commit/f759bda075298ec44e2b4fb57659a0c56620483b
- https://github.com/parse-community/parse-server/pull/10344
- https://github.com/parse-community/parse-server/pull/10345
- https://github.com/parse-community/parse-server/security/advisories/GHSA-mfj6-6p54-m98c
Get alerted when CVE-2026-34573 or the next vulnerability affects your stack