What’s Vulnerable › Vulnerabilities
CVE-2026-34574: Parse Server: Session field immutability bypass via falsy-value guard
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-697
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.69 and 9.7.0-alpha.14, an authenticated user can bypass the immutability guard on session fields (expiresAt, createdWith) by sending a null value in a PUT request to the session update endpoint. This allows nullifying the session expiry, making the session valid indefinitely and bypassing configured session length policies. This issue has been patched in versions 8.6.69 and 9.7.0-alpha.14.
Affected products
- parse-community parse-server: before 8.6.69; from 9.0.0 before 9.7.0; 9.7.0-alpha1, 9.7.0-alpha10, 9.7.0-alpha11, 9.7.0-alpha12, 9.7.0-alpha13, 9.7.0-alpha2 (+7) — fixed in 8.6.69, 9.7.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.69, 9.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/90802969fc713b7bc9733d7255c7519a6ed75d21
- https://github.com/parse-community/parse-server/commit/ebccd7fe2708007e62f705ee1c820a6766178777
- https://github.com/parse-community/parse-server/pull/10347
- https://github.com/parse-community/parse-server/pull/10348
- https://github.com/parse-community/parse-server/security/advisories/GHSA-f6j3-w9v3-cq22
Get alerted when CVE-2026-34574 or the next vulnerability affects your stack