What’s Vulnerable › Vulnerabilities
CVE-2026-34595: Parse Server: LiveQuery protected-field guard bypass via array-like logical operator value
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-843
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.70 and 9.7.0-alpha.18, an authenticated user with find class-level permission can bypass the protectedFields class-level permission setting on LiveQuery subscriptions. By sending a subscription with a $or, $and, or $nor operator value as a plain object with numeric keys and a length property (an "array-like" object) instead of an array, the protected-field guard is bypassed. The subscription event firing acts as a binary oracle, allowing the attacker to infer whether a protected field matches a given test value. This issue has been patched in versions 8.6.70 and 9.7.0-alpha.18.
Affected products
- parse-community parse-server: before 8.6.70; from 9.0.0 before 9.7.0; 9.7.0-alpha1, 9.7.0-alpha10, 9.7.0-alpha11, 9.7.0-alpha12, 9.7.0-alpha13, 9.7.0-alpha14 (+9) — fixed in 8.6.70, 9.7.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.70, 9.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/commit/f63fd1a3fe0a7c1c5fe809f01b0e04759e8c9b98
- https://github.com/parse-community/parse-server/commit/ffad0ec6b971ee0dd9545e1bf1fb34ddebf275c2
- https://github.com/parse-community/parse-server/pull/10350
- https://github.com/parse-community/parse-server/pull/10351
- https://github.com/parse-community/parse-server/security/advisories/GHSA-mmg8-87c5-jrc2
Get alerted when CVE-2026-34595 or the next vulnerability affects your stack