What’s Vulnerable › Vulnerabilities

CVE-2026-34637: Premiere Pro | Out-of-bounds Write (CWE-787)

Description

Premiere Pro versions 26.0.2, 25.6.4 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Premiere 25.6.5, 26.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-34637 or the next vulnerability affects your stack