What’s Vulnerable › Vulnerabilities
CVE-2026-34656: Adobe Commerce | Improper Authorization (CWE-285)
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-12 · updated 2026-10-26
- Weakness: CWE-285
Description
Adobe Commerce versions 2.4.9-beta1, 2.4.8-p4, 2.4.7-p9, 2.4.6-p14, 2.4.5-p16, 2.4.4-p17 and earlier are affected by an Improper Authorization vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized write access. Exploitation of this issue requires user interaction in that a victim must visit a maliciously crafted URL or interact with a compromised web page.
Affected products
- Adobe Commerce: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p10, 2.4.4-p11, 2.4.4-p12, 2.4.4-p13 (+65) — fixed in 2.4.4
- Adobe Commerce: before 1.3.3; 1.3.3, 1.3.3-p1, 1.3.3-p10, 1.3.3-p11, 1.3.3-p12, 1.3.3-p13 (+45) — fixed in 1.3.3
- Adobe Magento: before 2.4.6; 2.4.6, 2.4.6-p1, 2.4.6-p10, 2.4.6-p11, 2.4.6-p12, 2.4.6-p13 (+30) — fixed in 2.4.6
- Adobe Commerce: through 2.4.9-beta1, 2.4.8-p4, 2.4.7-p9, 2.4.6-p14, 2.4.5-p16, 2.4.4-p17
- Adobe Commerce: through 1.5.3-beta1, 1.5.2-p4, 1.4.2-p9, 1.3.4-p16, 1.3.3-p17
- Adobe Magento Open Source: through 2.4.9-beta1, 2.4.8-p4, 2.4.7-p9, 2.4.6-p14
How to fix
Upgrade to a fixed version: Adobe Commerce 2.4.4; Adobe Commerce 1.3.3; Adobe Magento 2.4.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34656 or the next vulnerability affects your stack