What’s Vulnerable › Vulnerabilities
CVE-2026-34687: Illustrator | Heap-based Buffer Overflow (CWE-122)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-12 · updated 2026-10-26
- Weakness: CWE-122
Description
Illustrator versions 29.8.6, 30.3 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: from 29.0 before 29.8.7; from 30.0 before 30.4 — fixed in 29.8.7, 30.4
How to fix
Upgrade to a fixed version: Adobe Illustrator 29.8.7, 30.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34687 or the next vulnerability affects your stack