What’s Vulnerable › Vulnerabilities
CVE-2026-34690: After Effects | Stack-based Buffer Overflow (CWE-121)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-12 · updated 2026-10-26
- Weakness: CWE-121
Description
After Effects is affected by a Stack-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe After Effects: before 25.6.5; from 26.0 before 26.2 — fixed in 25.6.5, 26.2
How to fix
Upgrade to a fixed version: Adobe After Effects 25.6.5, 26.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-34690 or the next vulnerability affects your stack